typo ... in paroli rev
[openmoko.git] / packages / pulseaudio / pulseaudio_0.9.10.bb
1 require pulseaudio.inc
2
3 DEPENDS += "dbus"
4 PR = "r4"
5
6 SRC_URI += "\
7   file://disable-using-glibc-tls.patch;patch=1 \
8   file://libpulsedsp-references-libpulsecore.patch;patch=1 \
9   file://pa-drop-caps-returns-void.patch;patch=1 \
10 #  file://libtool2.patch;patch=1 \
11   file://2113.diff;patch=1;pnum=0 \
12   file://2114.diff;patch=1;pnum=0 \
13   file://libiconv.patch;patch=1 \
14 "            
15
16 do_compile_prepend() {
17     cd ${S}
18     mkdir -p ${S}/libltdl
19     cp ${STAGING_LIBDIR}/libltdl* ${S}/libltdl
20 }
21
22
23 # problems w/ pulseaudio 0.9.10 atm:
24 # 1.) needs libltdl >= 1.5.24 (yes, any older version will NOT work at runtime)
25 # 2.) doesn't build w/ glibc TLS support (hence patched out)
26 # 3.) fails with hierarchical pthread stuff w/ gst-pulse (hence patched out)
27